Back to overview
Resolved

Website is down

May 20, 2026 at 12:51pm UTC
Affected services
Main Website
Jams
Radio

Resolved
May 20, 2026 at 1:28pm UTC

All fixed happy jaming

Updated
May 20, 2026 at 1:11pm UTC

Jams are disabled until we found the crashing error. The site can be down sometimes.

Created
May 20, 2026 at 12:51pm UTC

The NCR website is down for a lot of users. We are investigating this problem.